Back to overview
Resolved

Server Down for Hardware Maintenance

Aug 4, 2026 at 6:00am UTC  –  Aug 4, 2026 at 7:00am UTC
Affected services
tradetally.io

Resolved
Aug 4, 2026 at 7:00am UTC

Maintenance ended

Created
Aug 4, 2026 at 6:00am UTC

Tradetally will be down for about an hour to allow for a hardware upgrade.